Why doesn't YouTube video or other embedded media appear?

First, if you have not done so already, please read the support document:

How do I add images, video, documents, and other media to my EdBlogs posts and pages?

There are various reasons that videos embedded in your blog may not display for you. As a first step in troubleshooting, please make sure your browser is up to date and running the most recent version. Also, since many videos as this time require flash to play, please make sure your flash player plugin is up to date.

Get Flashplayer

If your video still does not play, you may have a security feature set on the browser that does not allow third party or mixed content considered to be insecure to be displayed. To enable third party and potentially insecure content, you must make changes to the settings of your browser. 

If you are having trouble viewing an embedded media object with your browser you may be experiencing a security feature that is blocking some of the media on your site from appearing. The security settings in Firefox, Chrome, and Internet Explorer often block third party content from appearing. Currently Safari does not block third party content from appearing.

This is a helpful document to learn more.

You may disable this setting on a page by page basis by following the directions below:

Firefox


Navigate to the page where the media is not appearing and look for a shield icon to appear in the address bar of your browser. Click on the shield icon and "Disable Protection on this Page".



For can make this change permanent by changing your security settings under the about:config. Learn more here. This extension may also work.

Chrome


Navigate to the page where the media is not appearing and look for a shield icon to appear in the address bar of your browser. Click on the shield icon and "Load unsafe script".



Learn more here.

Internet Explorer


Learn more here.


Please make sure the embedded media is from a safe source before opting to disable the security settings on your broswer. 

The embedded media should now appear. If it does not appear, please make sure you have it embedded correctly based on the document linked above. If you confirm it is embedded correctly and still have trouble, please email columbiaCTL+edblogs@columbia.edu or call (212)854-9058


EdBlogs

  1. As instructor, can I add users to my EdBlog?
  2. Can I invite guests to my EdBlog if they do not have a Columbia University ID (UNI)
  3. What languages does EdBlogs support?
  4. How can I migrate my EdBlog?
  5. How do I add images, video, documents, and other media to my EdBlogs posts and pages?
  6. How do I change the icon (Avatar) that appears next to students names in an EdBlog comment?
  7. How do I edit multiple posts at once?
  8. How do I get student names to appear in the sidebar with posts and comments tracked?
  9. How do I manage blog categories (add, edit, and delete)?
  10. How do I request an EdBlogs site?
  11. How do I resize images in an EdBlogs post so they appear correctly in the theme?
  12. How may I organize my course EdBlog with multiple authors writing regularly on new topics?
  13. Is there a way to make sure an EdBlog post stays at the top of the home page?
  14. My username appears on my course EdBlog as my UNI. How do I change this?
  15. What is the best way to add my syllabus to EdBlogs?
  16. Where can I find documentation about EdBlogs?
  17. Who may view the EdBlogs site for my course?
  18. Can my students use EdBlogs with a mobile device?
  19. What is the difference between categories and tags in EdBlogs?
  20. How do I change the title of my blog?
  21. Can I change the URL of my EdBlogs site?
  22. Why doesn't YouTube video or other embedded media appear?
  23. What types of files can be uploaded to EdBlogs?
  24. How do I add a link to my EdBlog in Courseworks?
  25. How do I customize the menu of my blog?
  26. How can I setup email subscriptions for my students?
  27. Why are my images appearing cropped?

Feedback and Knowledge Base